Skip to content

SecurityOpenSSL

Fixed

OpenSSL fixes 12 flaws credited to AISLE's AI analyzer, including a high-severity CMS stack overflow

OpenSSL at a glance

OpenSSL's January 27, 2026 advisory fixed 12 CVEs, all credited to Aisle Research; AISLE says its autonomous analyzer found every one. The most serious, CVE-2025-15467, is a pre-authentication stack overflow in CMS (Auth)EnvelopedData parsing. Fixes are in 3.6.1, 3.5.5, 3.4.4, 3.3.6 and 3.0.19.

OpenSSL: status

FixedHigh
Affected
  • OpenSSL 3.6.0 before 3.6.1, 3.5.0 before 3.5.5, 3.4.0 before 3.4.4, 3.3.0 before 3.3.6 and 3.0.0 before 3.0.19 (CVE-2025-15467)
  • OpenSSL 3.4, 3.5 and 3.6 before the fixed releases (CVE-2025-11187)
  • Some low-severity issues also affect OpenSSL 1.1.1 and 1.0.2 (fixed in 1.1.1ze and 1.0.2zn for premium support customers)
Status as of
Discovered by
AISLE's autonomous analyzer; OpenSSL credits Aisle Research (Stanislav Fort, Petr Šimeček, Tomas Dulka, Luigino Camastra) · Found by an AI system

What changed with OpenSSL

On January 27, 2026, OpenSSL published a security advisory covering 12 CVEs. The only high-severity one, CVE-2025-15467, affects parsing of CMS AuthEnvelopedData and EnvelopedData messages that use AEAD ciphers such as AES-GCM: an oversized IV in the message is copied into a fixed stack buffer before any authentication, so no valid key is needed. OpenSSL says this can crash the process and may allow remote code execution, depending on platform protections. Apps that parse untrusted CMS or PKCS#7 content, such as S/MIME, are exposed. OpenSSL 3.0 through 3.6 are affected; 1.1.1, 1.0.2 and the FIPS modules are not.

The rest are one moderate issue, CVE-2025-11187, a PBMAC1 validation bug in PKCS#12 MAC checks on 3.4 to 3.6, and ten low-severity bugs. OpenSSL credits Aisle Research for all 12, with CVE-2025-11187 also reported independently by Hamza of Metadust. In a January 26 post, AISLE says its autonomous analyzer found all 12, that its proposed patches were adopted directly for five of them, and that six more findings were fixed before the vulnerable code ever shipped. AISLE also credits OpenSSL maintainers with validating the reports and developing the final fixes.

Upgrade to OpenSSL 3.6.1, 3.5.5, 3.4.4, 3.3.6 or 3.0.19. A few low-severity issues also reach 1.1.1 and 1.0.2, fixed in 1.1.1ze and 1.0.2zn for premium support customers only. Most businesses do not install OpenSSL directly: it arrives through operating system packages, language runtimes and container base images, so update your distribution's packages, rebuild images and restart services that link it.

How to fix it: OpenSSL

  1. 1. Update

    Upgrade to OpenSSL 3.6.1, 3.5.5, 3.4.4, 3.3.6 or 3.0.19, matching your branch; premium support customers on 1.1.1 or 1.0.2 should move to 1.1.1ze or 1.0.2zn.

    openssl-library.org (opens in a new tab)
  2. 2. Update

    Apply your operating system or container base image updates for OpenSSL, rebuild images that bundle it and restart services that load it.

    openssl-library.org (opens in a new tab)

Advisories

Why OpenSSL matters for businesses

This release was one of the first large, officially credited batches of AI-found bugs in a core piece of internet security, and it shows the pace defenders now need to match. If your AI workflows ingest signed or encrypted email, documents or other CMS content from outside, that parsing path is where the high-severity bug sits. Treat dependency updates that carry security fixes as urgent rather than waiting for a quarterly cycle.

Sources for this story

  1. Official
  2. Vulnerabilities (opens in a new tab)

    OpenSSL · openssl-library.org

    Official
  3. Official

Last verified: . IA Compa summarizes public announcements for business readers. We are not affiliated with the companies mentioned. Always confirm details, pricing, and availability with the official source.

  • #security
  • #cve
  • #openssl
  • #ai-discovered
  • #cryptography
  • #patch-management

Want this working in your business?

We turn new AI capabilities into agents, voice receptionists, and automations you can actually use.